Announcement

Collapse
No announcement yet.

Microcode Studio + ICD, where are the variables?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • queenidog
    replied
    Variables are gone again - check this out

    I ran a short bit of code provided by Henrik and ran the ICD to check it out step by step. Lo and behold, the VARIABLES column was missing again, this time with a PBP program. I had to stop and restart PBP to get the variables column back again.

    Curious, I loaded the assembler program that I thought, initially was the reason why there was no VARIABLES column. Well, there IS a variables column when running an assembler program as well. In other words something else is causing the column to disappear, it has nothing to do with being assembler or BASIC.

    Don't believe me? See attached screen print.
    Attached Files

    Leave a comment:


  • queenidog
    replied
    I found out where the variables went to

    I found out why the variables disappeared.
    Running a PBP program in debug, they appear
    Running an assembler program in debug, the variables do not appear, likely because there are "none" as we know them.

    All is well in the universe.

    Leave a comment:


  • queenidog
    replied
    I swear they weren't there

    I swear, those variables weren't there. When I use the debugger, usually the ONLY, at least the most important, sections to keep tabs on are the variables. And all I saw were the 3 other columns. AFter trying a number of things to fix it (checking setup for example, trying to widen the columns, etc) and nothing worked, THAT was when I sent the question to this forum and also to Mecanique.

    Then for some equally inexplicable reason the variable column was suddenly there when I next opened MCS+ just as Mecanique contacted me for further information. I feel like an idiot when these things happen, wasting everyone's time but trust me, as a former "troubleshooter" I thought I had covered all the bases.

    Anyhoo...it works now and I CANNOT break it.

    Leave a comment:


  • David John Barker
    replied
    I got a direct email regarding this question but to summerise, a system restart solved the problem.

    Leave a comment:


  • Darrel Taylor
    replied
    Yo Dog,

    You should see the variables in the "Variables" tab on the right side of the screen during debugging.

    Here's a screenshot of MCSP 5.0.0.1

    http://support.melabs.com/DT/MCSP_Debug.jpg

    Leave a comment:


  • queenidog
    started a topic Microcode Studio + ICD, where are the variables?

    Microcode Studio + ICD, where are the variables?

    In previous versions of MCS+ (I'm using 5.0.0.1 to work with PBP3.0) entering the ICD debug mode would display not only registers, memory, and eprom, but also the variables used in the program.
    I don't see my variables anymore. Was this feature removed? Did I miss turning on some configuration bit somewhere so variables would be displayed?

    To me the variables are more important than memory and eprom.
Working...
X