Announcement

Collapse
No announcement yet.

MCS questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MCS questions

    I have two different projects on different tabs, in different folders using different chips

    when i switched between them using the tabs i was surprised (and pleased) to see the chip type changed automatically to the correct one

    how does it know? from the contents of program itself ? or is it stored in the registry or something ?

    i am thinking the latter because as i recall on a different machine when i had opened a project for the first time i had to set the chip type so i don't think it discovers them in the code

    are there plans for a new release ? there are some wishes ...

  • #2
    after pressing F9 there is a dialog with a lot of interesting information during compiling,
    but then it closes
    how can i preserve the information that was shown there?
    Number of warnings, number suppressed, lines assembled and so forth

    Comment


    • #3
      Hi Dennis,
      View -> Compile and Program Options -> MPASM Close After Assemble.
      Make sure it's not ticked.

      /Henrik.

      Comment


      • #4
        i knew it had to be there, and i had stared right at that option once, thanks again

        Comment


        • #5
          Originally posted by Henrik Olsson View Post
          Hi Dennis,
          View -> Compile and Program Options -> MPASM Close After Assemble.
          Make sure it's not ticked.

          /Henrik.
          apologies in advance, am sure i asked this before but could not find

          when i compile in MCS how do i display the PBP version and MPASM version used ?
          i like to document those and am sure i have seen that in the results window or somewhere ...
          thanks

          Comment


          • #6
            Hi Dennis,

            The MPASM version is displayed in the title bar of the window you asked how to get rid of.
            The PBP version that MCS is pointing to (and is using for compiling) is displayed if you do Help->About.

            Click image for larger version

Name:	Help.jpg
Views:	1
Size:	67.9 KB
ID:	5281

            /Henrik.

            Comment


            • #7
              great thanks, i think it was you that showed me this before Henrik

              so it appears my original install package (i had a recent computer meltdown) came w/ MPPLAB 8.90, now there is an 8.92, can i assume that the MPASM version is also incremented and is there any good reason to mess with this if my chips are supported as-is ?

              Comment


              • #8
                There's no good reason to move from 8.90 to 8.92 unless you need new device support.
                Charles Leo
                ME Labs, Inc.
                http://melabs.com

                Comment


                • #9
                  Wow Henrick, I would have thought that your system would have been upgraded to PBP 3.0.8.4 by now....
                  Dave Purola,
                  N8NTA
                  EN82fn

                  Comment


                  • #10
                    Nope, I updated the system I've got at work (separate licence) but haven't done my personal one yet. Did the work one to see if the new MPLABX would allow me to do source level debugging but, as before, I got nowhere - which you know if you've been following the other forum.

                    Don't currently have a need for the devices added in 3.0.8.4 so I see no need to mess with it at the moment.

                    /Henrik.

                    Comment

                    Working...
                    X