Announcement

Collapse
No announcement yet.

Mplab X

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mplab X

    Hi,
    MPLAB X is now released in v1.0 and I've been trying to get started with it.

    I've downloaded the MPLAB X Plugin from here and installed it by selecting Tool->Plugins->Downloaded->Install and then pointing to the downloaded .nbm file.

    I then go to File->New Project and move thru the dialogs untill I reach the Select Compiler dialog where PBP is shown in the list but with (None Found) after it and selecting it does not allow me continue the Project wizard.

    Anyone know how to get this working?

    Thanks!
    /Henrik.

  • #2
    We'll begin testing with the new release of MPLABX. Been expecting it to release.

    If I remember correctly, you must configure the tool after installing the plugin. In the beta it was Tools -> Options -> Embedded.
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

    Comment


    • #3
      Thanks Charles!
      I tried that, Tools->Options->Embedded->Build Tools->Add New Toolchain and then pointed it to the PBP3 install folder upon which it told me Base directory does not contain a toolchain.

      I think I'll just wait and hope for some kind of documentation/tutorial.

      Thanks!
      /Henrik.

      Comment


      • #4
        MplabX?

        Ok, I didn't get very far. But, I downloaded the Mplabx plugin. And was able to install it by going to MplabX >Tools >Downloaded >Add Plugin.

        Now I can see it listed under plugins, it shows:
        [ATTACH]352[/ATTACH]
        Then, I restart the application, and look for my newly added tool chain!:
        [ATTACH]351[/ATTACH]

        But it isn't there

        Any ideas?

        Comment


        • #5
          The plugin doesn't automatically add the toolchain. Click the button to Add and browse to the PBP3 folder. (Tools->Options->Embedded->Build Tools->Add New) The updated plugin will allow MPLABX to see the PBPX executable and know what to do with it. When you did this before, it was with the old plugin and MPLABX was looking for PBPW.EXE.

          Make sure you change the assembler location using the MPASM-MPLAB setup utility (Start->All Programs->PBP3 from melabs). It MUST point to the MPASMX folder within the MPLABX installation. (MPLABX will insist on using MPASMX.)
          Charles Leo
          ME Labs, Inc.
          http://melabs.com

          Comment


          • #6
            Thanks Charles,

            I have gotten to the point where I can compile in MPLAB X for PBP3, and I can run simulation, and step through my code with debug while in simulation. I have tested the hex file, and it is good. But I do get an error after compile, and I am not able to program using any of the programmers while in MPLAB X (tested to work for MPLAB X in C).

            I notice in MPLAB X PBP3, the .cof file is put in \dist\default\production file of the project, but the hex is left in the base file of the project. This is not how it works in MPLAB X C. The hex file and the cof file would be found in the \dist\default\production file for C. So I am wondering if the error I am getting is the rest of MPLAB not finding the hex where it thought it would be. This leads me to wonder if the plugin is set right? This doesn't look like any settings I can select, as far as I can tell.

            Here is a my compiling message:

            CLEAN SUCCESSFUL (total time: 101ms)
            make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf
            make[1]: Entering directory `C:/local/new/altimeter.X'
            make -f nbproject/Makefile-default.mk dist/default/production/altimeter.X.production.cof
            make[2]: Entering directory `C:/local/new/altimeter.X'
            gnumkdir -p build/default/production
            "C:\PBP3\PBPX.EXE" -ampasmx -k# -os -p12f683 alt-683.pbp
            PICBASIC PRO(TM) Compiler 3.0.4.4, (c) 1998, 2011 microEngineering Labs, Inc.
            All Rights Reserved.
            gnumkdir -p dist/default/production
            cp alt-683.COF dist/default/production/altimeter.X.production.cof
            rm -f alt-683.COF
            make[2]: Leaving directory `C:/local/new/altimeter.X'
            make[1]: Leaving directory `C:/local/new/altimeter.X'

            BUILD SUCCESSFUL (total time: 3s)
            Loading C:/local/new/altimeter.X/dist/default/production/altimeter.X.production.cof...
            The program file could not be loaded: File not found.

            Comment


            • #7
              Ok, that was with MPLAB X version 1.00

              With MPLAB X v 1.10, I get both files in the correct location. Looks like the rest is up to MPLAB, as was the original problem, its seems. If you have had any successes with MPLAB 1 or 1+, I would love to hear about it.

              Here is the compile with the files going to the right place:

              CLEAN SUCCESSFUL (total time: 101ms)
              make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf
              make[1]: Entering directory `C:/local/new/altimeter.X'
              make -f nbproject/Makefile-default.mk dist/default/production/altimeter.X.production.hex
              make[2]: Entering directory `C:/local/new/altimeter.X'
              gnumkdir -p build/default/production
              "C:\PBP3\PBPX.EXE" -ampasmx -k# -p12f683 alt-683.pbp
              PICBASIC PRO(TM) Compiler 3.0.4.4, (c) 1998, 2011 microEngineering Labs, Inc.
              All Rights Reserved.
              gnumkdir -p dist/default/production
              cp alt-683.HEX dist/default/production/altimeter.X.production.hex
              cp alt-683.COF dist/default/production/altimeter.X.production.cof
              rm -f alt-683.COF
              make[2]: Leaving directory `C:/local/new/altimeter.X'
              make[1]: Leaving directory `C:/local/new/altimeter.X'

              BUILD SUCCESSFUL (total time: 6s)
              Loading C:/local/new/altimeter.X/dist/default/production/altimeter.X.production.hex...
              Loading C:/local/new/altimeter.X/dist/default/production/altimeter.X.production.cof...
              Loading completed

              Comment


              • #8
                I successfully tested with MPLABX and the PICkit3, but it's been a while and I'm not sure of the MPLABX version that I was using. Since that time, my tests haven't gone farther than compiling and simulating. I'll try to repeat my results later today.
                Charles Leo
                ME Labs, Inc.
                http://melabs.com

                Comment


                • #9
                  Thanks Charles,

                  I was able to get it to run correctly and program with the programmers. For me, MPLAB X v1.10 got me past the problems. I think they had to do with the hex file ending up in one place, and the .cof file being in another with MPLAB X v1.00.

                  Now all functions appear to be working for me.

                  But if you have time, can you take a look at Marcick's java error:
                  http://www.picbasic.co.uk/forum/show...575#post112575

                  He is using 32 bit Windows 7, and I used 64 bit Win 7.

                  Not sure what this would be. Any ideas?

                  Comment


                  • #10
                    Originally posted by Charles Leo View Post
                    The plugin doesn't automatically add the toolchain. Click the button to Add and browse to the PBP3 folder. (Tools->Options->Embedded->Build Tools->Add New) The updated plugin will allow MPLABX to see the PBPX executable and know what to do with it. When you did this before, it was with the old plugin and MPLABX was looking for PBPW.EXE.

                    Make sure you change the assembler location using the MPASM-MPLAB setup utility (Start->All Programs->PBP3 from melabs). It MUST point to the MPASMX folder within the MPLABX installation. (MPLABX will insist on using MPASMX.)
                    How do you do this on a Mac OS with MPLAB X IDE?

                    Comment


                    • #11
                      PBP doesn't run on Mac OS.
                      Charles Leo
                      ME Labs, Inc.
                      http://melabs.com

                      Comment


                      • #12
                        Hi, Charles

                        I would like to know if the latestest versions of MPLAB (3.xx ) allow working with PBP : only my old Mplabx 2.35 accepts to show PBP programs in the program window, and works properly ...

                        no way to work in the source window with Mplab 3.xx ! ( Win XP SP3 or Win 7 show same behaviour ), But no problem with assembler or C.

                        but " funny " ( If I can say ...) thing is old projects compiled with 2.xx versions compile fine with v.3.xx - always not showing source listing -

                        Do you have any info about that ???

                        The Mplabx Forum is definitly deaf and mute about that ...

                        Alain

                        Comment


                        • #13
                          MPLABX 3.xx seems to be incompatible with the PBP plugins. I don't currently have access to a Java developer to fix it. I would be dragging my feet in any case because this is not the first time the plugins have been broken. It's frustrating to go through the process only to have to do it again next year.

                          I'll have to either find a Java guy or learn it myself. I don't think it's all that complicated, but it's difficult to fit it on my plate with everything else.
                          Charles Leo
                          ME Labs, Inc.
                          http://melabs.com

                          Comment


                          • #14
                            MPLABX 3 changed some of the plugin formats, but it seems to work if you deactivate/uninstall the "PicBasic Language Syntax" plugin via main menu -> Tools -> Plugins -> Installed tab -> check 'PicBasic Language Syntax' and then 'Deactivate'

                            After doing that I can open source files and compile in MPLABX 3.10

                            Comment


                            • #15
                              Hi, Charles and Jim (?)

                              thanks for the infos.
                              I'll have a try with the 3.10 release.

                              Alain

                              Comment

                              Working...
                              X