Announcement

Collapse
No announcement yet.

Problem programming Pic16F886

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem programming Pic16F886

    I compiled the simple test program BLINK provided by microEngineering Labs using the PICBASIC PRO COMPILER (PBP3) but when I tried to burn the code into the Pic16F886 MCU, using the meLabs Programmer, I get the error message 'Unable to Access any Port'. After several attempts, and a couple of different programs I wrote in the past, I decided to scrub my computer of the Compiler and Programmer and reload them. I'm still getting the same error message. The instructions for loading these programs are a little confusing, so I may not be loading them correctly.

  • #2
    First make sure you have the latest programmer software (4.64):
    http://melabs.com/support/progsoft.htm

    The programmer should show a green LED when connected. The computer should react with the USB "bing bong" sound when the programmer is plugged in. The error indicates that the software doesn't think there are any programmers connected.


    Charles Leo
    ME Labs, Inc.
    http://melabs.com

    Comment

    Working...
    X