Announcement

Collapse
No announcement yet.

MPLABX 5.10 new piece of crap ???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MPLABX 5.10 new piece of crap ???

    I just tried to upgrade to MPLABX 5.10 ...

    no way to use PBP (3.1 ) as a building tool :

    - downloaded the Plugin
    - entered PBP as the default tool ...

    everything looks fine except MPLABX answers it can't find PBP when hitting the " compile " button ...

    sooo, went back to v 5.05 and everything fine as previous.

    Has someone any pointers ???

    Alain

  • #2
    I usually fix all of my MPLABX related problems with a simple command - DEL C:\MPLABX

    Seriously though, I haven't tried 5.10 yet. Sometimes the plugins don't get set properly, so make sure you close and reopen MPLABX.

    Select 'Tools | Options | Embedded | Build Tools' and check that PICBASIC PRO is listed in the Toolchain listbox with the proper directories. At least that's where it used to be unless things have changed...

    Comment


    • #3
      Hi, Tumbleweed

      done all that, PBP appears where it has to ... but compile button raises a " PBP not found " alert window ...

      so, it it is one more good big BUG ...

      I pushed the DEL .... button and went back to a 5.05 running fine

      may I add ... BUT STILL WITHOUT the spelling corrector Charles should update ...

      Alain

      PS : bug confirmed by MPLABX forum ...
      Last edited by Acetronics; 11-19-2018, 12:55 PM.

      Comment


      • #4
        In the End ...

        PBP is now usable again within MPLABX 5.15 ...

        just needed 3 " little " months to get someting usable ...

        BTW ... What about the spelling tool that disappeared after V 2.35 ??? ( PicBasic Language syntax plugin, for the " Elders " )


        Do I ask too much ???

        Alain
        Last edited by Acetronics; 03-05-2019, 12:51 PM.

        Comment


        • #5
          When I tried installing the plugin in 5.15, it broke MPLABX so bad it wouldn't launch anymore. I hope your results hold up and mine were in error.

          The syntax highlighter was something we developed without any direction from Microchip. Since it worked on the NetBeans level instead of the MPLABX level, it was broken with every MPLABX update. We couldn't afford to keep it working, so I removed it from the Microchip repository.
          Charles Leo
          ME Labs, Inc.
          http://melabs.com

          Comment


          • #6
            Well I have been using PBP with MPLABX 5.10 for some time now. I have not seen any issues. I do not use any plugins with MPLABX however.
            Dave Purola,
            N8NTA
            EN82fn

            Comment


            • #7
              Too much is too much, Charles !!!

              PBP has been working for less than ... 24 Hours:

              PBP 3.1.1 works fine with MPLABX 5.15 ... I was Happy ...

              then ME raised V 3.1.2 ...

              and what is happening ???

              MPLABX doesn't see anymore PBP as a tool ...

              sooo ... the problem is coming from you, Charles

              Back to the starting blocks for 3 more Months ???

              I'm really furious ...

              Alain

              PS : reinstalled PBP 3.1.1 and ... everything fine !

              really a shame !!! .
              Last edited by Acetronics; 03-06-2019, 12:55 PM.

              Comment


              • #8
                After your last post I succeeded in making it work with MPLABX 5.15. Just pointed the plugin to PBP 3.1.2 and mine still works.

                I don't have enough information to definitively say that it's not a bug in the plugin, but the bug is apparently intermittent or related to another circumstance.

                I tested with plugin version 3.1.1, so I put it up for download at http://pbp3.com/downloads/com-melabs...-toolchain.nbm
                Charles Leo
                ME Labs, Inc.
                http://melabs.com

                Comment

                Working...
                X