Announcement

Collapse
No announcement yet.

MPLAB V8.92 with PBP3.0.10 how do I get LONG variables to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • superace
    replied
    Genious! Exactly what I was looking for, now I just have to change the config settings but that's not a major problem. Thank you for solving this

    Leave a comment:


  • tumbleweed
    replied
    in MPLAB8, select 'Project | Build Options... | Project | PICBASIC PRO' tab
    Check 'Use PICBASIC Pro Long (PIC18 only)', click 'Apply' and 'OK'

    That should change the command line options to '-n -ampasmwin -k#'

    Leave a comment:


  • DavidP
    replied
    I have always used Microcode Studio as my IDE and just specify Use Compiler Long Words from the compiler options tab. I have never used the command line options but the -n option is specified in the PBP 3.1 manual to work. I have used both of those processors in the past and have moved on to using the 18F27K40 and 18F47K40 processors.

    Leave a comment:


  • superace
    replied
    I use 18f4620 and 18f46k20 and other 18 series so it should work

    Leave a comment:


  • DavidP
    replied
    Superace, what processor are you compiling for? LONG's are only available for the 18F series processors.

    Leave a comment:


  • MPLAB V8.92 with PBP3.0.10 how do I get LONG variables to work

    I am a long time user of PBP2.6 and now I try to get a new computer up and running with PBP3. But I totally fail to understand how to get LONG variables to work with MPLAB 8.92.
    The "old" way used 2 different PBPW and PBPL files depending on what variant I wanted to use. The "new" way seems to just have one file PBPX. I can compile programs in MPLAB but only using Byte and Word sized variables. If I try to use LONG the compiler will give me a FATAL ERROR Line 89: LONG datatype not supported. Use -n option for LONG datatype support.

    So my question is how do I use -n option in MPLAB? Now that there are no PBPW and PBPL exe files anymore? With PBP2.6 I could work around this problem.

    In short: How do I activate the LONG version compiler in combination with MPLAB 8.92


    I do not want to switch over to MPLABX, I find that tool suite un-usable and it is a memory hog as well as a hard disk space eater. So using MPLABX is not an option.
Working...
X