Announcement

Collapse
No announcement yet.

MODEDEFS.BAS is ite still required on 3.1.1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MODEDEFS.BAS is ite still required on 3.1.1

    hi guys ,

    reviewing some old code that is to be re used / updated and has MODEDEFS.BAS as include , is this still needed any more or can it be dropped ?

    regards


    sheldon

  • #2
    If you are using certain communications protocols, it still needs to be included. PBP3.1.1 adds the newer 18FK42, 16F1xxxx and other PICs with radically revised addressing. Adding provisions for TIMER2/4/6 HLT, DMA, and the extended addressing for the K42 is why there was an additional charge for that update over 3.0. All the rules are pretty much the same. Exceptions will give you a notice at the bottom after you compile (such as "HPWM command only works with CCP module, not PWM module", etc).
    We can crack this cotton PIC'n thang!

    Comment


    • #3
      hi mike , it was included for the shift/in/out for the software spi coms use , used on 18f87k22, and k80 ( PBP3.08) , k40's (PBP3.1.1) currenlty for this version of code

      Comment

      Working...
      X