Results 1 to 6 of 6

Thread: 3.1 and MPLAB X Tutorial?

  1. #1

    3.1 and MPLAB X Tutorial?

    Just upgraded to the 3.1 and MPLAB X(was using 8).
    I've been looking around the forum and found a few things about migration up to the X program but nothing like a "complete" tutorial.

    MELabs have a version on the site for 8. Is there a one coming out for X?
    Or, have I just missed it?

    Thanks!

    Ian

  2. #2
    There's a video for setting up PBP in MPLABX: https://www.youtube.com/watch?v=2tHxbGHVR_4

    The MPLABX plugin won't be updated at Microchip for a while, so if you need to use the latest chips that PBP supports, you can find the latest plugin in your PBP 3.1 installation. Look for the folder "MPLABX Plugin". To install the plugin from your local computer instead of the Microchip cache, click Tools > Plugins as in the video, but go to the Downloaded tab instead of the Available Plugins tab. Click the Add Plugin button to browse for the plugin file. After that you can install it.
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  3. #3
    Hi, Charles

    I have a "little" problem trying to upgrade to PBP3.1 .... ( Win 10/64 system )

    1) If I install it, It installs in a new folder (PBP3_1) keeping the 3.0.10 folder as it.

    2) problem comes here ... now the new PBP asks for a registration

    3) IF I enter my registration code ... it replies " registration not valid "

    sooo,

    ... must I de-register my previous PBP ???
    ... must I uninstall PBP 3.0.10 before upgrading ???

    I just reached to have back some usable IDEs ... ( uninstalling v3.1 and reinstalling PBP 3.0.10 from zero ... over the previous installation ... )

    any pointers, please ???

    Alain

  4. #4
    I never recommend uninstalling/reinstalling PBP except as a last resort. If you think a PBP installation is corrupt, just reinstall and the files will be overwritten.

    The two installations (3.0 and 3.1) should not interfere with one another. You can keep both installed, then use the Microcode Compile and Program Options screen to select which compiler to use. They are each activated as separate applications with separate activation keys.

    The error message you've reported ( "registration not valid" ) isn't familiar to me. If that is the actual message, let me know and I'll investigate further. If the message is actually "invalid serial number", it indicates that the PBP Activation Manager is rejecting the key, most likely due to a version mismatch or an incorrectly entered key.

    Make sure you are running the PBP 3.1 Activation Manager and using a PBP 3.1 activation key. If you enter a PBP 3.0 activation key into the PBP 3.1 Activation Manager, it will reject it.

    PBP 3.1 activation keys are obtained by purchasing an upgrade to PBP 3.1. http://store.melabs.com/cat/PBPUP.html

    Run the PBP 3.1 Activation Manager by clicking Start > [All Programs] > PBP 3.1 from ME Labs, Inc. > PBP 3.1 Activation Manager.

    In the title bar of the Activation Manager, it will show version 1.2.0.3.1 to denote that it is the PBP 3.1 version.
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  5. #5
    If you enter a PBP 3.0 activation key into the PBP 3.1 Activation Manager, it will reject it.
    OK ... understood ... ( laughs ! )

    it was the 50 Bucks bug !!!

    Alain

  6. #6
    Sorry for not getting back sooner!

    Thanks Charles. As always excellent info.

    Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •