Results 1 to 18 of 18

Thread: Registration Manager errors

  1. #1

    Registration Manager errors

    I installed PBP3 on a Win 7 machine and am getting a "Unable to create directory" error when running the Registration Manager. I get the same error opening Microcode Studio, but it does open after.

    I've run both as administrator, but no joy.

    Happy to provide more info if needed, just hoping there's a simple (known) fix?

  2. #2
    Could you verify the error message? I'm guessing that it's actually the registry that is blocked.

    Here is an excerpt from the upcoming revision of the activation help document. Though your symptoms are a bit different, I suspect the problem is related:

    This indicates that our activation manager (melabsreg.exe) is unable to write to the registry on the computer. The activation process seems to work, but the activation data is not being recorded successfully. This can be due to anti-virus software, registry-protection software, modified access rights, or simply a corruption of the registry itself.

    Try temporarily disabling any anti-virus or security software.

    Some users have reported that starting Windows in "Diagnostic Mode" will allow the activation to complete.

    Also try at least one cycle of uninstall/reinstall for PBP.
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  3. #3
    Tried it again... turned AVG off, restarted. Same error. Trying reinstall now. Thanks for promptness!

  4. #4
    No go... Fails with same error, then gives MeLabsReg titled error # 50003. Same as before.

  5. #5
    Can you give me the exact wording of the error message?
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  6. #6
    Quote Originally Posted by Charles Leo View Post
    Can you give me the exact wording of the error message?
    The Exact wording is: "Unable to create directory". Once I push OK and additional error: "Unexpected error #50003" appears.

  7. #7
    This is one we haven't encountered before.

    The message "Unable to create directory" doesn't help, because the activation manager shouldn't try to create any directories.

    The message "Unexpected error #50003" is new to me, but a search on the web suggests that it's related to Visual BASIC runtime files and common controls. The current version of the activation manager is written in VB6.

    Did you receive any messages concerning dll/ocx registration during the PBP installation procedure?

    Is MS Visual BASIC installed on the computer?
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  8. #8
    No, I don't beleive that any of your concerns are an issue for me. The computer I normally run on is part of a home network and VB is installed on another node. Also, if it can affect the situation: PCP 2.6 installed without issue; the node is only used for my electronics bench so there isn't much on it...

    I get the same "Directory" error trying to compile from inside the application.

    I'm out of town at the moment, replying from my laptop, else I'd try to get more exact info.

    No Ocx or Dll messages

  9. #9
    How about MS Office 2010? Is it installed on the machine?

    Two users have reported that Office 2010 interfered with activation. One user uninstalled Office, activated, then reinstalled Office. The other experimented a bit and reported that activating in "Diagnostic Mode" worked, without uninstalling Office 2010.

    Did you try restarting in "Diagnostic Mode" or "Safe Mode"?
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  10. #10
    No MS Office at all. Not much of anything installed really. Some stuff Windows installs as part of W7 Home Premium--DVD maker, Explorer, etc... PBP 2.6 and associated. The only software I see that might be unique to me is "MicroCapture 2.0", software for a USB microscope.

    I did try "Safe Mode", but had no better luck. Does it seem odd to you that the software installs without a hitch, but registering is an issue?

  11. #11
    Senior Member
    Join Date
    Sep 2011
    Location
    australia
    Posts
    248

    similar problems

    i have have similar issues on my hp win 7 pro laptop and found that every thing worked better if install was run "run as administrator" and the microcode studio icon too

  12. #12
    Thanks, Richard, but I've tried that as well. I'm looking for a few hours to move my data to another node, reformat and reinstall. Though, honestly, the machine is so sparsely furnished with software that I wonder if it isn’t more a matter of something missing (VB runtime, some common .dll, etc) than some conflict.

    Whatever it is, I get the same error when trying to compile inside PBP3 as well. The only additional clue:

    “ERROR: Unable to instantiate pbpReg 8000ffff” in the Result window.

  13. #13
    We did encounter a similar "Unable to instantiate" message during development last year. I believe it was related to a registered file in the Windows\System32 folder. (Windows\SysWOW64 on 64-bit systems)

    The following files are placed in the folder. All except the .lic file are registered with the OS.:

    OneWayX.ocx
    OneWayX.lic
    pbpReg.DLL
    MSINET.OCX

    If I remember correctly, the cause was that one of the OneWayX files failed to be updated during our install. This resulted in a version mismatch. (These files may be installed and used by software other than PBP, but the PBP installer should be allowed to update existing files.) We modified our installer and haven't seen the error since then.

    I know that software from Trace Systems also uses the OneWayX files.

    You should verify that the files exist. If they are there, you might try renaming them and then reinstalling PBP.
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  14. #14
    I think we're getting somewhere! Found and renamed the files listed, except Pbpreg.dll as it was not in the directory. PBPSUITE.DLL exists, but no "reg". Anyway, I'm downloading now... I'll post results asap.

  15. #15
    Ok, a fresh install found PbpReg.dll (different directory) and stalled. A quick rename/ retry installed a fresh copy, but stalled again at pbpx.exe. I did the same--rename/ retry--and install continued without issue. Running melabsReg failed as before. Both "stalls" failed with an "Unable to delete file", but allowed renaming without issue. AVG was off through entire install and I ran setup as admin.

  16. #16
    I'm afraid that I can't quite visualize the process from your description. Anytime it stalls, I need to know which application is reporting an error and the exact error message.

    You mentioned that pbpReg.dll was found in a different location. Could you share the details?

    Is this a 32-bit or 64-bit system?

    It might make sense in this case to call our support number so that we can work on it in realtime.
    Charles Leo
    ME Labs, Inc.
    http://melabs.com

  17. #17
    Just a quick followup... I finally found the time to reformat and reinstall. It went without a hitch. I don't suppose that helps to troubleshoot much, but it does indicate to me that it was a conflict rather than a problem with PBP3 installer.

    Thank you for your attention and the promptness with which you addressed my issue; I have every confidence we'd have gotton to the bottom of it--if only I'd been willing to hold out and dig deeper.

  18. #18

    I have a similar problem

    Hello, i'm new here and a beginer with pbp. I'm trying to compile a .bas file with pbp toolsuite in mplab 8.92 and im getting this error: "Unable to instantiate pbpReg 8007007e". Please, help me. I've been reading some coments about somebody that had a similar problem. And i read something about
    a pbpreg.dll file in syswow64, but i didn't quite understand.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •