No announcement yet.

U2 Programmer Crash

  • Filter
  • Time
  • Show
Clear All
new posts

  • U2 Programmer Crash

    Been living happy go lucky with the U2 serial programmer, that is, until today. Started when I went to install the ME Labs Trainer to help get a youngster into the fun of programming. All started, well, Trainer fired up with preinstalled "Field" program running and it was time to try loading in some exercises. Loading appeared normal with a good completion message, but Trainer became non-responsive. Checked that device ID was correct, yep, good communication. Thought there might be conflict between the programmer in the Trainer board and the regular U2, went to the ME site to re-install the U2 code. Not good, first Windows came up with content warning and once that was cleared, Norton turned red and stopping the process cold. OK, used the DVD to install the U2 firmware, then firmware update online. Just to be sure, uninstalled the Trainer to bring it back to where the morning had started. Working meProg, verified correct device ID with the regular separate U2, and same with the programmer built in Trainer board. Next tried to open firmware hex file to do a code load, got total meProg freeze up. File drop down menu opened normally, clicking Open (file) not responsive at all. Worse after that, the meProg completely locked up. Only way to clear was Alt/Ctrl/Del to Task Manager and close the application there. Repeated with a re-install, same result. Computer re-start, reload meProg, no help.

  • #2
    I vaguely remember fighting a similar battle when I bought the Trainer board to work with my son (3 years ago??). Sadly, I forget what I did to fix the issue, as my son never took to the electronics side of things. (He is working on programming, but for gaming applications.)
    We can crack this cotton PIC'n thang!


    • #3
      Can you perform other operations before you open the file? Does the Help > About dialog come up or does it lock up on any menu selection?
      Charles Leo
      ME Labs, Inc.


      • #4
        Help/About works, IDs melabs Programmer Version 4.67. Help/Readme is good too. Program/Devide ID works. Then get message to update programmer firmeware by going to Options/Options/Update firmeware. That clicks OK, but freezes up after that, task manager only way to get out of that.


        • #5
          Switched computers to one that has no MELabs apps. Went to install meProg_467_setup.exe online from ME Labs. System message "was blocked because it could harm your device."


          • #6
            Third computer... installed meProg from disc, all good. Hooked up trainer, all working. Go figure!