No announcement yet.

MicroCode Studio has stopped compiling

  • Filter
  • Time
  • Show
Clear All
new posts

  • MicroCode Studio has stopped compiling

    I haven't had a programming project going lately but the last time I did, MC Studio worked just fine. I am running Win 7 Pro- 32 bit.
    Maybe a file or path got corrupted somewhere.
    I thought I might reinstall MC Studio but I couldn't find int on the MEL website.
    My PBP3 source disk is away in a box in a storage building and I didn't really want to go digging for it if unnecessary.
    I am using the USB programmer not an onboard programmer for this project. Although I have the Trainer board which does and have also used it with great success in the past.
    MicroCode uses MPASM right? Could is be that MPASM went bad or the path to it got buzzed up?

    All suggestions for debugging this problem would be appreciated. It has been a while since I installed PBP3 and set things up.

  • #2
    Have you tried different PIC part numbers? When you say it doesn't compile, are there error codes, or just like you never clicked the Compile button? Is it doing anything?

    Technically speaking, MicroCode Studio is the IDE and PBP is the Compiler. Don't know if that helps you figure it out.
    We can crack this cotton PIC'n thang!


    • #3

      It is like I never clicked the button. I have cleared out all the normal files in the folder except the .pbp source code and there is nothing there after clicking the "Compile" (not the "Compile and Program") button. No errors and no MPASM v5.62 window pops up and displays the green progress bar.

      I have never seen that condition before. It makes me wonder if the MPASM part of the process got buzzed up. It shouldn't have gotten "updated" behind the scenes because as far as I know I haven't had any interaction with MicroChip's website for years and my system is never kept online over the Net when I'm not intentionally using it.

      Should I not get some files if the compiler is working and the assembler is not? I don't remember in what sequence they run in but I thought the assembler ran last from my courses in computer science many years ago..


      • #4
        To All:

        I just discovered something that should help make this less difficult to de-bug.

        First it is useful to know. I ran MC Studio on my laptop and was presented with a slight difference from on the desktop. I purchased the MEL Trainer a while ago and it uses the on-board programmer and debug function. The "dashboard" of MC Studio on my laptop has all of the on-board complile, program and debug controls greyed out and it works as I expect it to when I hit the "Compile" button. However I noticed on the "dashboard" of MC Studio on my desktop has the "Compile" , "Compile and Program" and debug commands all in full functioning state. Refer to the following screenshot:

        Click image for larger version

Name:	Hint.jpg
Views:	157
Size:	49.9 KB
ID:	7968My conclusion is that MC Studio is behaving in a way that it thinks it is connected to the Trainer board even though it is not. It is my intention to compile for the stand-alone USB programmer.
        This problem will be solved when I can get MC Studio to stop thinking the Trainer board is the output device.

        Any help here?


        • #5
          I thought I had better include a few more screenshots to provide all the context info. Please note that the paths, etc. all check out as correct:

          Click image for larger version

Name:	Options.jpg
Views:	188
Size:	41.1 KB
ID:	7970Click image for larger version

Name:	Compilers.jpg
Views:	189
Size:	22.9 KB
ID:	7971Click image for larger version

Name:	Programmers.jpg
Views:	196
Size:	34.0 KB
ID:	7972


          • #6
            Try running the PBP Activation Manager and reactivating PBP.

            The toolbar difference is just a setting you can change under View > Toolbars
            Charles Leo
            ME Labs, Inc.


            • #7
              Charles, thanks for the Instructions.
              That was all it took to get the compiler back!