Announcement

Collapse
No announcement yet.

I can't get the program to run

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Christiansen
    Junior Member

  • Christiansen
    replied

    Same issue still no fix to this.
    tellpopeyes
    Christiansen
    Junior Member
    Last edited by Christiansen; 11-30-2021, 05:02 AM.

    Leave a comment:

  • Walter05
    Junior Member

  • Walter05
    replied
    Originally posted by Henrik Olsson View Post
    In MicroCodeStudio, you have to select a target device for which an ICD header file is available (16F887 for example). If such a file is not available for the selected device (16F1512 for example) the buttons will be disabled. The header files are located in the ICD Models folders within the MCSPX installation folder, have a look there for what devices are supported out of the box.

    If you want to run the ICD on a device for which a file is not available there's the View->ICD Model Creator menu option to assist you in creating a header file for that particular device. Note that not all devices CAN use the ICD due to lack of hardware USART.

    /Henrik.
    tellthebell
    Thanks for the update and quick reply. I'll be sure to keep an eye on this thread. Looking for the same issue. Bumped into your thread.
    Walter05
    Junior Member
    Last edited by Walter05; 11-21-2021, 09:07 PM.

    Leave a comment:

  • Nicholas9677
    Junior Member

  • Nicholas9677
    replied
    After I install the PBP 3.0 to 3.1 upgrade on my new computer and rebooted the computer, the ICD buttons on MicroCode Studio Plus 5 were blue and appeared active. But then after a few minutes ICD buttons when grey. I could not get the ICD compiler to work like it was working on my old computer. My Milestone Card

    Leave a comment:

  • Charles Leo
    Administrator

  • Charles Leo
    replied
    I don't see an ICD model file for the 18F4685 in the default set. Am I missing it?

    Did you create one before? It might be a matter of copying it from the old machine.

    Leave a comment:

  • mpgmike
    Senior Member

  • mpgmike
    replied
    Send Charles an email at [email protected] and see if you can get his attention that way. You deserve to get what you paid for.

    Leave a comment:

  • Mark__
    Junior Member

  • Mark__
    replied
    Hi. I’m using a PIC18F4685, program size is plus 57K, so that’s not the problem. On my old and new computer I used my email [email protected] to create my Microsoft account. Each time I logged into my old computer, I would have to change the logon password before I could get on. When I went back to my new computer, I would have to change the logon password again to get on.

    After I install the PBP 3.0 to 3.1 upgrade on my new computer and rebooted the computer, the ICD buttons on MicroCode Studio Plus 5 were blue and appeared active. But then after a few minutes ICD buttons when grey. I could not get the ICD compiler to work like it was working on my old computer.

    I then purchased a new license for the full PBP 3.1 Gold. The problem has not changed. I still can not use the ICD compiler. I need help

    Leave a comment:

  • Henrik Olsson
    Senior Member

  • Henrik Olsson
    replied
    In MicroCodeStudio, you have to select a target device for which an ICD header file is available (16F887 for example). If such a file is not available for the selected device (16F1512 for example) the buttons will be disabled. The header files are located in the ICD Models folders within the MCSPX installation folder, have a look there for what devices are supported out of the box.

    If you want to run the ICD on a device for which a file is not available there's the View->ICD Model Creator menu option to assist you in creating a header file for that particular device. Note that not all devices CAN use the ICD due to lack of hardware USART.

    /Henrik.

    Leave a comment:

  • Mark__
    Junior Member

  • Mark__
    started a topic I can't get the program to run

    I can't get the program to run

    Hi, My old computer had PBP 3.0 gold, with MicroCode Studio Plus on it. It started to over heat, so I had to replace it with a new computer. On the new computer I purchased a new license for the PBP 3.0 to PBP 3.1 upgrade, and MicroCode Studio Plus 5. The In Circuit Debugger (ICD) buttons turned blue, but only for a minute, then turned gray and will not work. I called up, and was told that it should work because it was a full download. No matter what I did, I could not get the upgrade to work. I then purchased the full PBP 3.1 gold, and installed that. I still can’t get the In Circuit Debugger (ICD) buttons to turned blue and function like the MicroCode Studio Plus is supposed too. I need help.
Working...
X